Verbling is temporarily unavailable
Incident Report for Verbling
Resolved
Service is now back to normal on verbling.com . Please contact support@verbling.com with any questions or to resolve any issues. Thank you for your patience.
Posted about 2 years ago. Feb 19, 2017 - 09:29 PST
Investigating
We are aware of temporary service disruption on verbling.com and are working to restore it as quickly as possible. Please contact support@verbling.com with any questions or to resolve any issues. We are here to help! Thank you for your patience and an update will follow shortly.
Posted about 2 years ago. Feb 19, 2017 - 09:16 PST