Ongoing service disruption
Incident Report for Verbling
Resolved
Service is now back to normal on verbling.com . Please contact support@verbling.com with any questions or to resolve any issues. Thank you for your patience.
Posted about 2 years ago. Feb 19, 2017 - 09:57 PST
Investigating
We are currently investigating ongoing, partial service disruption. Please contact support@verbling.com with any questions to resolve any issues. Thank you for your patience and an update will follow shortly.
Posted about 2 years ago. Feb 19, 2017 - 09:37 PST